Servo stuck in one position

Hanail
Posts: 3
Joined: Mon May 21, 2018 11:01 pm

Servo stuck in one position

Postby Hanail » Mon May 21, 2018 11:09 pm

Hello,

I had issues with the "Setting Servo Center Position" step for one of the servos. I attached the servo arm, but I cannot rotate it left or right. It makes a humming sound but barely moves either way. The other servos were straightforward to adjust so I am wondering if this one has a manufacturing defect. Do you have any suggestions on how to fix this?

Thank you!

spierce
Site Admin
Posts: 32
Joined: Thu Sep 29, 2016 6:43 pm

Re: Servo stuck in one position

Postby spierce » Wed May 30, 2018 5:42 pm

Hi Hanail,

I apologize for the delayed response and the issue you're having with one of your servos.

Just to clarify, when centering the servo, since the servo isn't plugged in, there should not be a humming noise when trying to rotate the servo to the centered position. If it is plugged into the mePed PCB and powered up, the servo will automatically center itself and stay locked in the centered position and you will not be able to rotate the servo arm by hand.

If the servo does center itself when powered up, everything should be fine. If the servo is still not functioning properly, please email me your address and I can ship a replacement servo to you.

Thanks,
Scott Pierce

Hanail
Posts: 3
Joined: Mon May 21, 2018 11:01 pm

Re: Servo stuck in one position

Postby Hanail » Fri Jun 01, 2018 10:04 pm

Thank you for the reply. I ended up ordering a new set of servos online and finished assembling the robot. It was unplugged when I was trying to rotate it. I will try your suggestion when I use it on the next project.

The robot works great except one small issue. Sometimes it repeats the last command even if I press a different button. Turning it off and then on again fixes it. For example I press button 2 for a wave, it waves. I then press forward and it waves again instead of going forward. This happens several times even if I press other buttons. It eventually stops repeating the previous command and does the new one.

Do you have any suggestions on how to fix this?
The IR sensor is a bit bent, so I am wondering if this is an issue with the remote. I don't mind replacing it if you think that is the cause.

Hanail
Posts: 3
Joined: Mon May 21, 2018 11:01 pm

Re: Servo stuck in one position

Postby Hanail » Fri Jun 01, 2018 10:09 pm

I just read the troubleshooting guide and it seems related to remote interference. Having the remote closer to the IR sensor helps but doesn't fully fix it.


Who is online

Users browsing this forum: DraidecerseGes and 0 guests